Range Rover Velar Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter · #1 ·
Only had the car a few days and when running at low speed or standstill a gassy/aluminium smell comes into the cabin. Phoned dealer and they said it's probably the engine manifold heating up and it may smell for a few 100 miles or so and till it is run in a bit more. Anyone else had the same issue? If it continues more than another week I'll take it back in to get looked at.
 

·
Registered
Joined
·
421 Posts
Only driven mine for ten miles but after driving I could smell something burning which smelt like the brakes which is normal I guess for a new car as everything is worn in
 

·
Registered
Joined
·
126 Posts
Discussion Starter · #5 ·
mge.92 said:
Only driven mine for ten miles but after driving I could smell something burning which smelt like the brakes which is normal I guess for a new car as everything is worn in
Obviously the same smell. Wife won't go in the car until the smell goes, every cloud! 😂
 

·
Registered
Joined
·
295 Posts
Just got our D180 velar 10 days ago and only drove less than 400 km so far including highways , standard roads and traffic jams in Paris. Never had the smell issue. Apart from a warm rubber smell most probably from the tires after my first km on the highway. I suppose this is quite normal.
 

·
Registered
Joined
·
51 Posts
mine had the same, totally normal, went away after a few hundred KM/couple weeks.
 

·
Registered
Joined
·
2 Posts
Hello

First post.
I have an issue with a diesel like smell entering the cabin. I have FE 300D, now at 1900 miles and the smell seems to be getting worse. I did initially think it was new car smell.
Smell seems worse in stop start traffic, but I think it is there all the time! On long journeys makes me feel ill. Passengers have noticed it as well.
Anyone experienced this?
Thanks
 

·
Registered
Joined
·
558 Posts
Could be injector seal, exhaust seal. I'd take it back in ASAP.
 

·
Registered
Joined
·
2 Posts
I have a similar problem and also a noise which sounds like a brake caliper dragging. Burning smell comes from the NSF wheel area and is only noticeable when driving slowly around town. Car has now done 4100 miles so unlikely to be new car burn in. Anyone noticed something similar?
Dealer not much help so far.
 

·
Registered
Joined
·
43 Posts
@sierrafoxtrott - Sounds like the same problem as I have. It's not constant though, and I can't seem to figure otu what triggers it. Usually lasts about 5-10 min and then stops again. Haven't had in in the last two weeks, still hoping for it to disappear. I'm at 5000km, FE D300.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top