Range Rover Velar Forum banner
1 - 20 of 47 Posts

·
Registered
Joined
·
534 Posts
Discussion Starter · #1 ·
So ICTP is pretty awful with an iPhone imo.

Bluetooth works flawlessly, But when I plug my phone in via usb the system constantly freezes and/or stops working in some other manner. It seems to be most stable if I plug the phone in BEFORE starting the car. If I plug the phone in once the car is on, or unplug my phone and reconnect it...it's game over. Unusable. I have an iPhone 7, latest iOS.

When it works....I absolutely love the system. Voice control to play a specific artist, album, or song is very accurate and simple and the interface itself is more visually pleasing than Apple Carplay imo. Hopefully a future update will fix the instability. For all I know, the dealer didn't even update mine to the latest version as it was one of the first cars built. Does anyone else have the same issues?

The digital instrument panel has been relatively trouble free, though it is definitely a bit slow to respond. You have to really push the buttons hard to make selections as well. The lower display that controls the vehicle dynamics and climate has been flawless and fast though...zero problems with that.

Overall I'm disappointed in execution of the tech in this seemingly tech-focused vehicle and hope it improves over time with updates. I love the car itself though. It drives fantastically and I suppose that's most important.
 

·
Registered
Joined
·
421 Posts
It helps if you load up the app on your phone first before you plug in the phone. Try that.
 

·
Registered
Joined
·
8 Posts
agreed. Terrible connectivity on both iphone and android. Needs attention.
 

·
Registered
Joined
·
22 Posts
I have the same problems.
Also I have the problem that when using the handsfree phone he sounds freezes regularly so you stop hearing your correspondent for about 4 to 6 seconds. Very very annoying. Use iPhone 7 plus with latest IOS.
Regular problems also with the main TFT. I have the map in the middle between the two round meters. This disappears sometimes. At that time the Velar silhouet comes into place and the HUB looses the NAV directions. Only way to reset is stop the car, cut engine, lock it and wait at least 2 minutes until its is completely shut down and the IT is reset.
Really hope this will be solved quickly by VLR.

Car itself drives flawlessly. Ver pleased with performance and ride.
 

·
Registered
Joined
·
79 Posts
EriksVelar said:
Regular problems also with the main TFT. I have the map in the middle between the two round meters. This disappears sometimes. At that time the Velar silhouet comes into place and the HUB looses the NAV directions. Only way to reset is stop the car, cut engine, lock it and wait at least 2 minutes until its is completely shut down and the IT is reset.
I'm experiencing the same issue. When my nav disappears, I turn on & off cruise control. Because the info pane updates with a cruise cancelled message, this is enough of a prompt to get the info pane to starting working again. Hopefully the next software update will fix the issue.
 

·
Registered
Joined
·
252 Posts
KRG said:
Ever since I stopped plugging in my phone and started relying on Bluetooth, I've had no issues.
But then you cannot use InControl??
 

·
Registered
Joined
·
252 Posts
mge.92 said:
It helps if you load up the app on your phone first before you plug in the phone. Try that.
So Sequence is:-

Start Car
Open Apps on Phone
*THEN Connect to USB*
InControl Launches

Additional question, Spotify on InControl, anyway to search by Artist?
 

·
Registered
Joined
·
128 Posts
Having the same problems when plugged in via USB with iPhone 7 with latest iOS update. Bluetooth seems to work and I can see the phone in the media menu but it is greyed out (when plugged in via USB) and not accessible. The phone indicates it is connected so no idea what is happening. Got it to work once earlier this week but it is hit and miss, mostly miss at this point unfortunately
 

·
Registered
Joined
·
295 Posts
threeputt said:
Having the same problems when plugged in via USB with iPhone 7 with latest iOS update. Bluetooth seems to work and I can see the phone in the media menu but it is greyed out (when plugged in via USB) and not accessible. The phone indicates it is connected so no idea what is happening. Got it to work once earlier this week but it is hit and miss, mostly miss at this point unfortunately
+ 1
I've had excatly the same situation. Iphone 6S is plugged in USB and connected in bluetooth. I can strem music over bluetooth but I also see the iphone as an IPod in the media menu but it's greyed and can not be selected.

I was hoping to do side by side sound comparison betwin USB and air stream.

in addition. getting the Incontrol apps worked once this morning at the 1st connection. then it was impossible to get the 'Incontrol' to work again. I can see 'In control' button in the menu but nothing happens when I clik on it. I tried to shut down the car but it did not help. I'll give it a try with the procedure described above in this post following a specific order. could
 

·
Registered
Joined
·
295 Posts
mrgandfriends.co.uk said:
So Sequence is:-

Start Car
Open Apps on Phone
*THEN Connect to USB*
InControl Launches

Additional question, Spotify on InControl, anyway to search by Artist?
After having a few difficulties in launching IncontroI App on the Velar, I confirm that it does work well when following the step-by-step procedure mentionned above. weird it's not more 'plug and play' though

having said that I must say that the music menu from incontrol is nothing but finished. it does show a (very small) part of your titles, one can't browse by artits or by album from the big screen. icons are ugly (too big and thus pixelized) not a decent customer experience.

This must be a subject for JLR CRC if not adressed already : Amellia if you are reading us ...
 

·
Registered
Joined
·
128 Posts
I received a response from JLR North America, they were absolutely zero help. There response was, go to your nearest dealer. They said all technical questions, advice and recommendations are handled through our authorized dealer network. No help at all.
 

·
Registered
Joined
·
295 Posts
threeputt said:
I received a response from JLR North America, they were absolutely zero help. There response was, go to your nearest dealer. They said all technical questions, advice and recommendations are handled through our authorized dealer network. No help at all.
Hi Threeputt : I find it weird that an official JLR customer service does not bring you a clear feedback on these issues. There are 2 issues actually :
1/ how to properly get the InControl apps to work . the correct answer is to follow the steps described above in this post (1. start car. 2. open apps on Iphone. 3. connect usb). this kind of answer could be brought by both CRC and dealer. I could understand CRC pushing users toward dealership for such 'handling' questions so that dealership improve their level of competence on ICTP in general...
2/ poor / bad music navigation within the 'Incontrol app' when using USB. All what I describe below is not applicable to bluetooth link that worked perfectly for me. The issue I identified is the USB link. This is 100% a marketing issue, hence CRC related, not dealership IMHO. JLR has to improve the system so that one can decently browse music through ICTP / IC APPS, when using the USB link. Still missing so far :
- can not see Ipod / basic USB stick with music on it through ICTP. Iphone is recognized as an Ipod but the icon is grey and can not be selected. USB sticks simply do not appear
- when properly USB connected via the IC Apps, the music menu shows a very partial list of my the music titles
- browsing by title by artists, album ,etc is not possible
- bizarre icons display in music mode (some pixels)

kind of feel like a free of charge beta tester here :)

@ Amellia, this must be an issue for CRC please
 

·
Registered
Joined
·
252 Posts
Its a bad example of a 'integrated' solution I see. Of course, once they have sold you the car, the interest in your as a customer has been lost :) It happens I guess!

However, it would be encouraging to see if something changed either a downloadable upgrade to the software, or a dealer upgrade.

I did notice last night that my REMOTE App on iOS was updated, but nothing for either the Apps or Navigation apps.

Time with tell I guess :)
 

·
Registered
Joined
·
128 Posts
I have exactly the same issues as you are experiencing, also had the remote app to update when turned my phone on this AM. Said it was to improve network connectivity. Another issue is displaying of the tracks in the HUD, that does not work either despite it being selected in the HUD menu.
 

·
Registered
Joined
·
534 Posts
Discussion Starter · #19 ·
Yeah, mine is still awful...even when following the steps listed above, it still shows up greyed out 50% of the time and defaults to bluetooth. My bluetooth is also spotty now, cutting out fairly frequently, so I can't even rely on that. This is a massive issue as far as i'm concerned, and hopefully they address it soon.

I wonder how many of us actually have the latest software. I wouldn't be surprised if dealers didn't bother updating before delivery.
 

·
Registered
Joined
·
295 Posts
Ludo said:
threeputt said:
I received a response from JLR North America, they were absolutely zero help. There response was, go to your nearest dealer. They said all technical questions, advice and recommendations are handled through our authorized dealer network. No help at all.
Hi Threeputt : I find it weird that an official JLR customer service does not bring you a clear feedback on these issues. There are 2 issues actually :
1/ how to properly get the InControl apps to work . the correct answer is to follow the steps described above in this post (1. start car. 2. open apps on Iphone. 3. connect usb). this kind of answer could be brought by both CRC and dealer. I could understand CRC pushing users toward dealership for such 'handling' questions so that dealership improve their level of competence on ICTP in general...
2/ poor / bad music navigation within the 'Incontrol app' when using USB. All what I describe below is not applicable to bluetooth link that worked perfectly for me. The issue I identified is the USB link. This is 100% a marketing issue, hence CRC related, not dealership IMHO. JLR has to improve the system so that one can decently browse music through ICTP / IC APPS, when using the USB link. Still missing so far :
- can not see Ipod / basic USB stick with music on it through ICTP. Iphone is recognized as an Ipod but the icon is grey and can not be selected. USB sticks simply do not appear
- when properly USB connected via the IC Apps, the music menu shows a very partial list of my the music titles
- browsing by title by artists, album ,etc is not possible
- bizarre icons display in music mode (some pixels)

kind of feel like a free of charge beta tester here :)

@ Amellia, this must be an issue for CRC please
My previous post was a bit too harsh plus imprecise. i shall correct this.
When using the Incontrol apps menu, I wrote initially that the "music" menu was poor (thought there was. No browsing) . In fact it isn't poor. One can browse by artist , album, etc. You just have to click on a small icon on top with a small disc or a "thick". Once you do this you then have access to standard music menus.
 
1 - 20 of 47 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top