Range Rover Velar Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi All, anyone experienced an issue with Velar AC? It periodically shuts down even though fan continues to work but throws warm air and then after 10-15 minutes it would start working again - quite strange behavior and just recently started ..... any idea? Thank you.
 

·
Super Moderator
Joined
·
428 Posts
Have had software glitch that seems to cause that. A number of suggestions on the forum, but the one that works for me is to switch climate from auto to manual and then back again and then to Lo to max and back again.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Have had software glitch that seems to cause that. A number of suggestions on the forum, but the one that works for me is to switch climate from auto to manual and then back again and then to Lo to max and back again.
Thank you - I will try that and got appointment scheduled with JLR dealer as well.
 

·
Registered
Joined
·
170 Posts
Have had software glitch that seems to cause that. A number of suggestions on the forum, but the one that works for me is to switch climate from auto to manual and then back again and then to Lo to max and back again.
Similar situation here. In our case, it's fairly predictable. The A/C will blow hot when you stop for a short amount of time and then restart the car (e.g., to fill the tank on a long trip). We've noticed that spinning the dial to Lo for about 30 seconds resets the system and then you can put it back on the desired temp.
 
1 - 5 of 5 Posts
Top