Range Rover Velar Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
I took the iPod I was using in my BMW (cover art displayed fine) but when I plug it into the Velar the songs play but the cover art does not show up. I have it plugged in to one of the USB ports in the centre console. All I get is some generic music symbol for every song. Any ideas?? It is an older iPod so perhaps that could be the problem??
 

·
Registered
Joined
·
727 Posts
Try with an Iphone and see if it works? If you don't have one try it with a friends...most probably ipod is not being recognized properly by the car - do they still make ipods!?!? Thought everyone would have their music on their phones so maybe it'snot supported being such a new car? It's the first car I have had without a CD slot too!
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #5 ·
I tried it on my iPhone and cover art appears over Bluetooth without an issue so I will start using that if necessary. The iPod was just for convenience since I had been using it in my previous vehicle without issue.
 

·
Registered
Joined
·
534 Posts
I have the opposite issue. The cover art does not work for me over bluetooth...I get bizarre pictures of the artists that look like they were pulled from a generic google search, sometimes they're not even the right person...so strange. Over USB the cover art is 100% accurate all the time.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #9 ·
Tried USB and it works fine as long as I open the app first then plug in the phone. If I don't do that, I can see the phone but it is greyed out. One thing at a time I guess, now to figure out the HUD, phone calls incoming and outgoing work great and name is displayed as to who is calling with the green phone icon showing once call is answered. Can't get the media to show up, even though box is ticked in the HUD menu. Also on the HUD display, I thought it supposed to show the gears as you went through them, anyone get that to work. I have it check marked in the menu as well.
 

·
Registered
Joined
·
558 Posts
I have this same issue with the Evoque. Plug in USB with app open and it's fine. Bluetooth is hit and miss sometimes greyed out other time half the album art.
 

·
Registered
Joined
·
295 Posts
threeputt said:
Tried USB and it works fine as long as I open the app first then plug in the phone. If I don't do that, I can see the phone but it is greyed out.
this kind of feedback is really precious to JLR, so that they can back test and debug. does anybody know if they are reading this very forum or is there another place on line where such 'issues' can be officially posted to the manufacturer. sorry for asking but I guess wea are all interested in improving the system
 

·
Registered
Joined
·
1 Posts
KRG said:
I have the opposite issue. The cover art does not work for me over bluetooth...I get bizarre pictures of the artists that look like they were pulled from a generic google search, sometimes they're not even the right person...so strange. Over USB the cover art is 100% accurate all the time.
I'm having the same issue. Have you fixed it?
 

·
Registered
Joined
·
534 Posts
Alanxkly said:
KRG said:
I have the opposite issue. The cover art does not work for me over bluetooth...I get bizarre pictures of the artists that look like they were pulled from a generic google search, sometimes they're not even the right person...so strange. Over USB the cover art is 100% accurate all the time.
I'm having the same issue. Have you fixed it?
I haven't. I just keep my display on the home screen so I don't have to see the tacky images. I really hope this system improves. I'm just dealing with it until (hopefully) carplay arrives in an update...it's been rumored forever.
 

·
Registered
Joined
·
449 Posts
I had a request to customer service in the HQ. They went back to the department in charge. They approved that Apple Car Play is coming some time in the future, but could not commit that the existing systems can be updated to it. Sounded like a no to me. Well, thats the disadvantage of being an early adopter.
As I see it, Apple Car Play wouldn't be necessary if JLR gets the iPhone connection stable. What could definitely be accomplished by an update at the dealer.
 

·
Registered
Joined
·
295 Posts
no need for sat nav anymore with apple car play. I suspect JLR will sell car play only to those having purchased ICTP pack...

when car play arrives I would really feel spoiled if I could not get it with simple update.
 
1 - 17 of 17 Posts
Top