Range Rover Velar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I'm new to the forum. I've just taken delivery of a D300 R Dynamic and one week in, I'm really enjoying the car. Being a serial Range Rover owner, this is my sixth, I'm familiar with common gremlins and patchy dealer service - but keep coming back. Not sure if anyone else has experienced this yet, but the lower touch screen has stopped responding. It seems to be in a 'lights on no one at home mode'. The rotary controls will still change settings like driving modes, climate and seats, but none of the other touch controls will work. I now think I've discounted my own stupidity so any help appreciated. By the way, I have contacted dealer and the earliest they can see the car is 6th November!!
 

·
Registered
Joined
·
128 Posts
That does not sound like good customer service at all, especially for someone that is on their sixth Range Rover. I would be having a chat with management if it was me, especially as you say the vehicle is one week old.
 

·
Registered
Joined
·
482 Posts
PhilE said:
Hi, I'm new to the forum. I've just taken delivery of a D300 R Dynamic and one week in, I'm really enjoying the car. Being a serial Range Rover owner, this is my sixth, I'm familiar with common gremlins and patchy dealer service - but keep coming back. Not sure if anyone else has experienced this yet, but the lower touch screen has stopped responding. It seems to be in a 'lights on no one at home mode'. The rotary controls will still change settings like driving modes, climate and seats, but none of the other touch controls will work. I now think I've discounted my own stupidity so any help appreciated. By the way, I have contacted dealer and the earliest they can see the car is 6th November!!
Very strange. We are now 2,000 miles into ownership. The touch screens have been faultless. I suspect it's a dealer job, sadly.

Arianne
 

·
Registered
Joined
·
44 Posts
I'm at 1200 and touchscreens fine.
Issue with the map scrambling on the dash screen when set for the middle info panel. Has to reset via the steering wheel controls. Happened twice now so dealer next time as I plan to record it.
 
1 - 6 of 6 Posts
Top