Range Rover Velar Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
All - how do you use the feature where you enter your destination in an app - which i think is routeplanner - so that it shows up in the car when get in car?

In the car, the maps app keeps asking me to sign into my account which it says is provided by HERE. However when i sign up in the car it says problem not currently working.

Can anyone here help?

Thx!

Jeff
 

·
Registered
Joined
·
252 Posts
Hiya

So you need to register for a Here account at:

https://landrover.here.com/

Then you'll be able to login on the ICTP.

Next if you want to send locations to the car login to the LR navigation app on your "generic" smart device or on a full web browser.

Find and map you location and say start. Then it's gets sent to the car. I've found recently this has been a little hit and miss for some reason and it's been slow getting to the car sometimes taking a day which is nuts as it should be instant.

Hopefully this helps anyway
 

·
Registered
Joined
·
295 Posts
Yes it s working and it s brilliant. You just type your destination on the app onto your smartphone while at home and when you reach your car, you find it immediately in your ´recent' destination. No more painful typing on the car screen :) its am ust have

By the way the sat nav trafic ( with a data sim of course) is pretty accurate compared to waze
 

·
Registered
Joined
·
74 Posts
Excellent, it was my initial concern: having a super setup and still having to use waze on my phone
It is good to know it is working at least in Paris, what carrier are you using for the 3g?
I plan to use my dual sim card with my bouygues subscription.
 

·
Registered
Joined
·
14 Posts
USA. Mine didn't work. I can see where the car is, but the ATT sim card only worked for a few minutes the first night. (according to ATT). Brought it back to dealer. Everything checks out. Called ATT. They couldn't get contact. Said take it to the dealer. The in car wifi works, in that you can connect to it. But that's all. Not sure what I'm missing but other than trying another sim card, not much I can do.
 

·
Registered
Joined
·
295 Posts
peterd said:
Excellent, it was my initial concern: having a super setup and still having to use waze on my phone
It is good to know it is working at least in Paris, what carrier are you using for the 3g?
I plan to use my dual sim card with my bouygues subscription.
Hi peter !

I ordered a sim from laposte mobile for 5 €/ month and I do have 4G most of the time. I purchased this in october and there was a bundle with universal music and 10Go data for only 5 / month for the first year. I 'll have to switch in a year time. no big deal. I am used to do this for the kids :)
 

·
Registered
Joined
·
6 Posts
roverforlife said:
Won't let me attach photo for some reason. After i login, i get a message that says

"Sorry there is a problem on our end. Please check back later."

It's been 2 days still doesn't work!
Were you able to get it working. Mine has been saying this ever since I bought the car three weeks ago.
 

·
Registered
Joined
·
9 Posts
Hello,

I have for nearly 2 months (since about when I received my renewal reminder) my car has the mysterious message when using the Velar to log into Navigation:

  • "Sorry. There was a problem on our end. Please sign in later".

This is through the Sim with 4 bars of 4G or with Wifi connection. JLR themselves have not yet been able to fix it (via Facebook enquiries over the last week) and my dealer does not seem keen to address it.

I have had half an hour on the phone with EE to establish that the Sim is working with data fine when taken out of the car and put into an iPhone. But according to my EE bills the Sim has transmitted/received 0.00000MB of data while in the car during about the last 6 weeks after many months of working.

Things that work are: the map can be updated using laptop and USB stick as usual. The car reports its journeys, status and position fine to Incontrol. The car knows the status of its Incontrol subscription. The car cannot see weather or news or log into Incontrol.

Any ideas please, thank you. Very stuck.

James ;)
 

·
Registered
Joined
·
9 Posts
H, quick update. After diagnosis from LR and then the Incontrol team via FB Messenger, we established this could not be fixed at home and I must go into a dealer for a "Vehicle Shared Secret" update. This did not fix it but a new telematics module did. I had thought the telematics module was fine but clearly not as all is now fine. I have to say that the dealer were really good in comms with me. The car was outside warranty period but they did it under the warranty anyway after quickly establishing in a 20 second verbal "survey" that I am "brand advocate": this means I said I like the car, have owned JLRs before and may well buy one in future.
 
1 - 13 of 13 Posts
Top