Range Rover Velar Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hi all, first post on this forum. As many of you have had some glitches, so have I.

Besides window fogging issue, which I currently have the "zip tie" fix, I have experienced:

Live features not working, dealer had my vehicle for 2 days. They did some sort of software update and its working now.
Upper touch screen was all "snow". Apparently a software issue, it didn't "take" and they had to reflash everything.

Now, my current weirdness, is the upper touchscreen will randomly reboot. It will go black, tilt flat, and then turn back on but stay tilted flat. It doesn't do it every time, only randomly. It has happened about 5 times after they fixed the live features issue with whatever software update that was.

has anyone else experienced this? It definitely seems like there are still some software issues with this vehicle/system. I so far have not had any problems with the lower touchscreen.

Thanks all! Good information on here.
 

·
Registered
Joined
·
5 Posts
I have had these same issues with my new SE, that I just got as of Nov, mostly it is the lower screen going black. Also issue with my air turning off and staying off for about an hour... Terrible issue with condensation in the car as well. Not happy with my new purchase.. I FEEL YOUR PAIN!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top