Speakers crackling amongst other things

Faults and Technical chat for the Range Rover Velar
roberoo
Posts: 56
Joined: Fri Jan 18, 2019 2:10 pm
Location: UK

Re: Speakers crackling amongst other things

Post by roberoo » Fri Apr 12, 2019 8:18 pm

Updated to 19a2

S19A_19.11.4-330884

Still got audio crackle


Sent from my iPhone using Tapatalk
D300 R-Dynamic HSE 2018


Richie.A
Posts: 45
Joined: Mon Apr 01, 2019 7:44 pm
Location: Canada

Re: Speakers crackling amongst other things

Post by Richie.A » Sat Apr 13, 2019 5:53 pm

Hooman wrote:
Mon Apr 01, 2019 2:47 pm
Software updated to 19A ten days ago and I did not hear any Crackling noise till last night. I think this issue is related to weather and temperature. I live in Canada and in February it was around -15 and I had the noise every single day, then weather warmed up for around 2 weeks and it was above zero and I did not hear any crackling till last night that it was -5 and crackling stated again.
This to me makes sense as amps can be sensitive to extreme temperatures but you'd expect an amp designed for a vehicle (a luxury one no less) would account for such factors.

I suggest everyone who has the crackling issue not to use any audio until the interior of the car warmed up (or cooled down) to comfortable Temperature.

The amp is usually in sides of the car at boot and possibly behind sound and temperature insulation.

My velar is about 1 week away.
  • 2007 Mustang V6 Conv
  • 2010 RR Sport HSE SC
  • 2012 Audi A6
  • 2018 RR Velar P380 First Edition


Nunp
Posts: 51
Joined: Fri Nov 09, 2018 11:55 pm
Location: UK

Re: Speakers crackling amongst other things

Post by Nunp » Sat Apr 13, 2019 7:26 pm

I’ve had the audio crackling on 3 occasions since picking the car up 2 weeks ago. In all occasions this happened during the day and not first thing when car was cold but did when I drove off / reversed before the nav and media had fully loaded up and operational. Might be sheer coincidence but I now sit in the car for a short while, ignition on, wait until all systems are up and then drive off. Strange but appreciate this may not be the solution / issue.
D180 R-Dynamic SE in Corris Grey, 21 10 Spoke Satin Grey alloys, Privacy glass, Ebony grained leather, Fixed panoramic sunroof, Smartphone pack, No Roof Rails, No Derivative and/or Engine Badge


msarshid@gmail.com
Posts: 14
Joined: Fri Jul 27, 2018 10:19 am
Location: UK

Re: Speakers crackling amongst other things

Post by msarshid@gmail.com » Sun Apr 14, 2019 10:50 am

So my car was updated last week to 19A or thr latest software. I have an ongoing complaint with JLR in regards to this issue and the inconvenience it has caused.

I was categorically and repeatedly assured that this software update was THE FIX. It is a known issue and this would resolve the issue.

Guess what? (This is probably getting boring at the amount of times I have asked that question and answer has been the same)

IT HASNT BEEN FIXED!!

Now I have hit the roof with them as I am not waiting over a month for a slot at the garage and not accepting a discovery sport SE as a loan vehicle.

So the complaint handler has booked the vehicle in for next week with a like for like loan vehicle whilst the garage “carry out further diagnosis”

One would think they would have done this at the beginning when the fault was reported over 6 months ago.

Whether its an amp, cold start or frequency at the end of the day I have paid for a luxury car which seems to have faults you would expect from a budget brand. Not acceptable!

As always will keep you updated on any progress!


Garyccollings
Posts: 4
Joined: Sun Apr 14, 2019 9:50 am
Location: UK

Re: Speakers crackling amongst other things

Post by Garyccollings » Sun Apr 14, 2019 11:30 am

D300 HSE
R dynamic with meridian

have a similar tick tick tick sound when phone or music device is connected via usb
Weird. It’s the same with all cables and other phone/devices - iOS or Android makes no difference

Car is with dealer now to resolve together with driveshaft issues

Will keep you posted on progress


BootneckShuffle
Posts: 135
Joined: Tue Nov 20, 2018 4:32 pm
Location: UK

Re: Speakers crackling amongst other things

Post by BootneckShuffle » Sun Apr 14, 2019 2:44 pm

Gotta agree with msarshid above, this sort of shit just isn’t acceptable. This is an expensive vehicle from a presumably luxury brand, speakers that crackle for whatever reason simply shouldn’t happen PERIOD. My 2 week old Velar had the crackling again this morning, sounds like it’s playing some old record or something, dreadful.

Land Rover can best sort it out!


Richie.A
Posts: 45
Joined: Mon Apr 01, 2019 7:44 pm
Location: Canada

Re: Speakers crackling amongst other things

Post by Richie.A » Wed Apr 17, 2019 12:09 am

Has this problem been apparent in all of the speaker options on the velar or just the Surround?
  • 2007 Mustang V6 Conv
  • 2010 RR Sport HSE SC
  • 2012 Audi A6
  • 2018 RR Velar P380 First Edition


MildishGambino
Posts: 3
Joined: Thu Mar 28, 2019 2:28 pm
Location: Germany

Re: Speakers crackling amongst other things

Post by MildishGambino » Thu Apr 18, 2019 11:43 am

For me crackling occurs in every speaker option (meridian, Dolby, surround)


Ralph1
Posts: 25
Joined: Sun Apr 22, 2018 8:16 pm
Location: Germany

Re: Speakers crackling amongst other things

Post by Ralph1 » Thu Apr 18, 2019 3:33 pm

Hi, i only have the „Poor“ version of the Velar, R-Dynamik S, with the 380W Meridian Soundsystem, but, finger crossed, no problems so far! Great car!
R-Dynamic S 180d, Corris grey, Pan Roof, Acorn, ext. Leather, priv. Glass, Roof rails, tow bar, home link, etc..


Nick
Posts: 88
Joined: Sat Nov 10, 2018 12:11 am
Location: UK

Re: Speakers crackling amongst other things

Post by Nick » Thu Apr 18, 2019 8:14 pm

I have experienced this fault from day one back in Oct 2018 - I think it is on every Velar the ones that say is ok believe it’s happening you just not aware of it. I have 2 Velars same fault my brother bought a 19 plate - drove out of showroom same fault.

Getting so cheesed of with it they updated to the new 19A saying it a defo fix it made it worse. So drove it to dealers whilst it was happening the engineer came out taken a audio recording of the fault- shall now raise a warranty claim against JLR he thinks it’s the Amp as it happens on all sources or may be a loose connection somewhere.
Hopefully they can finally fix. You pay £55k plus for a car you expect it to work !


Post Reply

Return to “Faults & Technical”