Land Rover Route

New to the Range Rover Velar Forums? Introduce yourself here
Haybrd
Posts: 137
Joined: Wed May 01, 2019 12:39 pm
Location: UK

Re: Land Rover Route

Post by Haybrd » Mon Sep 09, 2019 12:55 pm

I had this happen yesterday (route issue). Spotted mobile data was off, turned it back on and fixed the issue then 30 mins later same again, switched it back on, 30 mins or so later it had switched off again....

Went to check SIM card and maybe clean it (I only got it Wednesday but you never know, the SIM card wasn’t fully inserted! It had clicked when I put it in originally but I pressed it in with a key and got a louder click. Been fine ever since.

Might not be the same cause as your issues but worth noting and checking.
MY20 D240 R-Dynamic SE, Santorini Black, 14 way heated, memory seats, Heated/power recline rear, 20” 7 spike gloss black wheels, Electrically deployable towbar, Fixed panoramic roof, Rear seat release , Power pack 2


Sjbatpsl
Posts: 10
Joined: Mon May 27, 2019 8:49 pm
Location: UK

Re: Land Rover Route

Post by Sjbatpsl » Mon Sep 09, 2019 4:04 pm

Thanks for the heads-up. It has been fine now since mobile data was turned back on.

Just astonished me that the car had been back to the dealer after consultation with JLR yet no one spotted that mobile data was turned off!!

Hopefully some good may come from it & someone has learnt to check mobile data before changing bits & pieces!

The ‘parking brake hold’ is still an issue that no one seems willing to even acknowledge though. Come on JLR - it’s a legal case waiting to happen.


Simonh
Posts: 128
Joined: Thu Jul 18, 2019 9:44 pm
Location: Shropshire, UK

Re: Land Rover Route

Post by Simonh » Mon Sep 09, 2019 4:21 pm

Yeah my parking brake hold sometimes works but mostly not especially with Stop/Start on a slope. Quit disconcerting !
Velar HSE D240 - MY19 (1st Range Rover and my 10th LR now)
Served by the excellent Shukers Land Rover of Ludlow - 20 years of amazing customer service.


Post Reply

Return to “Introductions”