Any one tried the S mode

All Range Rover Velar related discussions
Nick
Posts: 65
Joined: Sat Nov 10, 2018 12:11 am
Location: UK

Re: Any one tried the S mode

Post by Nick » Mon Feb 11, 2019 1:44 pm

Dani 80
You shall not have any issues in this mode, give it a blast!!


Drove this morning to work - nice country roads
It was a pleasure to drive - S mode all the time from now on.


Dani80
Posts: 53
Joined: Fri Jul 27, 2018 3:52 pm
Location: UK

Re: Any one tried the S mode

Post by Dani80 » Mon Feb 11, 2019 5:14 pm

Nick wrote:
Mon Feb 11, 2019 1:44 pm
Dani 80
You shall not have any issues in this mode, give it a blast!!


Drove this morning to work - nice country roads
It was a pleasure to drive - S mode all the time from now on.

Nice one Nick - will try it tonight. Hopefully doesn't do much to the fuel economy, as already sitting at an average of 27mpg (mostly city driving)!!
MY2019 Velar D180 R-Dynamic SE
Santorini Black
Black Pack
Privacy Glass
Ambient Lighting


Nick
Posts: 65
Joined: Sat Nov 10, 2018 12:11 am
Location: UK

Re: Any one tried the S mode

Post by Nick » Tue Feb 12, 2019 1:55 pm

You know what - I actually checked this last night,
I mainly to a 12 mile trip one way to work mix 6 miles on m-way and rest local roads
I normally get 35mpg in the mornings
Eve I get 41mpg. Dnt know how like !
In S mode and Dynamic - in the mornings 32mpg
Eve 38mpg.

I think I may need to check over a longer period though.


J77
Posts: 591
Joined: Sat Jun 16, 2018 6:38 pm
Location: Scotland

Re: Any one tried the S mode

Post by J77 » Tue Feb 12, 2019 2:50 pm

A Land Rover is the wrong vehicle if you’re worried about fuel economy.

Just drive it and enjoy 👍🏻
🏴󠁧󠁢󠁳󠁣󠁴󠁿 18MY R-Dynamic SE D240 Fuji White


KRG
Posts: 524
Joined: Fri Apr 28, 2017 1:25 pm
Location: USA

Re: Any one tried the S mode

Post by KRG » Tue Feb 12, 2019 3:06 pm

I’ve never tried D; always in S lol.
18 Velar R-Dynamic SE P250, Narvik Black/Eclipse


CRC@LandRover
Posts: 38
Joined: Wed Oct 04, 2017 7:56 am
Location: UK

Re: Any one tried the S mode

Post by CRC@LandRover » Wed Feb 13, 2019 12:54 pm

Dani80 wrote:
Mon Feb 11, 2019 1:26 pm
Must try Dynamic and S a bit more. I've been noticing bad lag when pulling off from junctions in my D180 - quite dangerous in the mornings, when I'm pulling out onto busy roads.
Good Afternoon Dani80

I am deeply concerned to learn of your comments. I would like to take the opportunity to investigate your concerns further.

May I request that you send the following details via PM:

Your Vehicle Identification Number (VIN)
Your personal contact details

Many Thanks

Dan - Land Rover UK


J77
Posts: 591
Joined: Sat Jun 16, 2018 6:38 pm
Location: Scotland

Re: Any one tried the S mode

Post by J77 » Wed Feb 13, 2019 3:54 pm

Every LR I’ve owned suffered lag to some degree. My D240 has it in abundance, it’s another LR quirk.
🏴󠁧󠁢󠁳󠁣󠁴󠁿 18MY R-Dynamic SE D240 Fuji White


tyrrell
Posts: 31
Joined: Thu Nov 01, 2018 4:57 am
Location: UK

Re: Any one tried the S mode

Post by tyrrell » Wed Feb 13, 2019 4:35 pm

I would say every car review both written and on car site reviews comments on lethargic getaways from Auto box diesels left in either eco mode or Comfort mode pulling out of junctions or traffic light get a ways.

They all do it, one reason why mine when it arrives will be left in S mode from the get go.


J77
Posts: 591
Joined: Sat Jun 16, 2018 6:38 pm
Location: Scotland

Re: Any one tried the S mode

Post by J77 » Wed Feb 13, 2019 5:33 pm

It doesn't bother me as I'm used to it and as you say its not unique and there is work arounds.
🏴󠁧󠁢󠁳󠁣󠁴󠁿 18MY R-Dynamic SE D240 Fuji White


Post Reply

Return to “Main Range Rover Velar chat”