Poor DAB signal

All Range Rover Velar related discussions
Post Reply
User avatar
Numbnuts
Posts: 14
Joined: Mon Mar 11, 2019 10:24 pm
Location: South West, UK

Poor DAB signal

Post by Numbnuts » Mon Apr 15, 2019 6:47 pm

Does anyone else have an issue with very poor DAB signal? I also have a Discovery 5 and the DAB on that doesn't drop out anywhere near as much as it does on the Velar. Even the FM signal doesn't seem to be that good compared to the Disco.


cianelectric
Posts: 71
Joined: Wed Oct 04, 2017 10:30 am
Location: UK

Re: Poor DAB signal

Post by cianelectric » Mon Apr 15, 2019 10:00 pm

I have very poor DAB, but I realised after a while my rear dash cam interferes with it :-(
D240 SE Corris / Acorn Leather with lots of options (including extended leather, aluminium door trim, sliding roof, air suspension, electric tow bar, activity key)
Thinkware dashcam front and rear


User avatar
Numbnuts
Posts: 14
Joined: Mon Mar 11, 2019 10:24 pm
Location: South West, UK

Re: Poor DAB signal

Post by Numbnuts » Mon Apr 15, 2019 10:18 pm

I wish mine was as easy as that to diagnose but I have got nothing external plugged in.

I assumed it was just the rural area of Devon that we live in that was the problem but we have just had 5 days in Manchester and gave the Velar its first proper run out and I was hoping that it would fair better in a more built up area but it was just as bad on the journey up there and also driving around the area.


yasmar
Posts: 32
Joined: Tue Mar 19, 2019 1:23 am
Location: Scotland

Re: Poor DAB signal

Post by yasmar » Tue Apr 16, 2019 12:01 am

I used to have a Discovery Sport that had ostensibly the same level of Meridian as I currently have ,11 speakers 380W or such like. To give an example I could drive from Edinburgh to London and have receptions all the way, yes I’d get spooling a few time and here the same piece of information twice but at least it didn’t lose signal entirely as the Velar seems to around Tebay on the M6.

At the moment it’s early days for me and I’m keeping an eye on it but it’s a bit disappointing on what is otherwise a great car.
MY19.5 2.0D 180 R-Dynamic S Velar in Firenze Red with panoramic roof, privacy glass, 20" Black 7 split-spoke alloys (7014)
Gone MY16.5 DS HSE 2.0 Litre Diesel Automatic Scotia Grey with privacy glass and mudflaps and many others!


Davidsolman
Posts: 2
Joined: Mon Apr 08, 2019 11:41 pm
Location: UK

Re: Poor DAB signal

Post by Davidsolman » Tue Apr 16, 2019 3:13 pm

I had same problem on Porsche Macan. Typical at dealers location it worked fine so they could not find fault. I read that it can be the receptor for dab signals that needs changing. Awaiting delivery of HSE version hopefully DAB works !!


david-DJ
Posts: 18
Joined: Thu Oct 19, 2017 10:17 am
Location: UK

Re: Poor DAB signal

Post by david-DJ » Tue Apr 16, 2019 4:42 pm

Yes, I have experienced drop out for long periods in the country, even when near a town or on main road.


EmmaS
Posts: 46
Joined: Thu Apr 26, 2018 8:42 pm
Location: UK

Re: Poor DAB signal

Post by EmmaS » Tue Apr 16, 2019 8:28 pm

I have black spots where I live happens at the same spots in my velar as it did in my jaguar, I’ve also had odd days where DAB drops out altogether...?


GSudhir
Posts: 30
Joined: Sun Dec 30, 2018 11:59 pm
Location: UK

Re: Poor DAB signal

Post by GSudhir » Tue Apr 16, 2019 9:51 pm

I had BAB problems in my previous Beemer, but it turned out that it was my USB phone charger which was plugged in to my 12V socket which was causing interference with the DAB signal!!!
In the Velar, I plug my phone in to the USB port and nothing in plugged in to the 12V socket and I have no problems with DAB signal.
Try disconnecting everything you might have connected to you 12 socket to see whether it makes a difference.
D300 R Dynamic HSE in Corris Grey with 1033 21 inch alloys
Pano sun roof
Configurable ambient lighting
360 camera
Windsor perforated leather- heated, cooled massage seats


GSudhir
Posts: 30
Joined: Sun Dec 30, 2018 11:59 pm
Location: UK

Re: Poor DAB signal

Post by GSudhir » Wed Apr 17, 2019 9:58 pm

GSudhir wrote:
Tue Apr 16, 2019 9:51 pm
I had DAB problems in my previous Beemer, but it turned out that it was my USB phone charger which was plugged in to my 12V socket which was causing interference with the DAB signal!!!
In the Velar, I plug my phone in to the USB port and nothing in plugged in to the 12V socket and I have no problems with DAB signal.
Try disconnecting everything you might have connected to you 12 socket to see whether it makes a difference.
D300 R Dynamic HSE in Corris Grey with 1033 21 inch alloys
Pano sun roof
Configurable ambient lighting
360 camera
Windsor perforated leather- heated, cooled massage seats


GSudhir
Posts: 30
Joined: Sun Dec 30, 2018 11:59 pm
Location: UK

Re: Poor DAB signal

Post by GSudhir » Wed Apr 17, 2019 9:59 pm

GSudhir wrote:
Tue Apr 16, 2019 9:51 pm
I had DAB problems in my previous Beemer, but it turned out that it was my USB phone charger which was plugged in to my 12V socket which was causing interference with the DAB signal!!!
In the Velar, I plug my phone in to the USB port and nothing in plugged in to the 12V socket and I have no problems with DAB signal.
Try disconnecting everything you might have connected to you 12 socket to see whether it makes a difference.
D300 R Dynamic HSE in Corris Grey with 1033 21 inch alloys
Pano sun roof
Configurable ambient lighting
360 camera
Windsor perforated leather- heated, cooled massage seats


Post Reply

Return to “Main Range Rover Velar chat”