Tech Issues

Faults and Technical chat for the Range Rover Velar
Post Reply
WagMatt
Posts: 1
Joined: Wed Mar 07, 2018 10:03 pm
Location: Canada

Tech Issues

Post by WagMatt » Wed Mar 07, 2018 10:13 pm

Hi all,

I see there are a lot of posts already but I don't have the time to go through everything to see if my issues are there!

Just got my Velar back after a "mouse" got into engine bay and ate an emissions wire causing the car to break down on me on the highway! Also had a list of things for them to look at but nothing too drastic.
Thankfully Land Rover footed the bill of replacing the wire and also giving me a new rear tire after they found a slow puncture.... I'm happy as those 22 inch wheels are expensive! The fact they replaced the wrong tire requiring another trip to Land Rover was an honest mistake!

Anyway sorry to ramble but here are my remaining problems:

1) Sometimes when I start the car and drive off, the drivers info page doesn't load the Sat Nav screen. It just shows the image of the car. Now I have tried what I believe is everything to get it to show the sat nav but the only thing that works is to turn the car off and walk away, then come back and restart it from fresh.
Any one else had this issue?

2) SatNav again: on the drivers display, when you have a route to follow it sometimes gives you a couple of options of route as you are driving. Now, on the Main Sat Nav centre screen it tells you what time saving you will get by going either of these routes, but the drivers sat nav screen shows the START time of your journey for both route options... So if I leave home at 1000am, the main screen will say, go this way and you will arrive at 1050am or go this way and you will arrive at 1045am. But the drivers screen shows both routes as 1000am.....! No use at all!


Anyway sorry for writing so much. I get carried away. Other than this I fooking love the Velar. Head turning esp in the silicon silver with black package and the 22 inch black rims!!!

Cheers and good day,

Matt


P380NarvikEclipse
Posts: 436
Joined: Sat Sep 30, 2017 3:18 am
Location: NYC

Re: Tech Issues

Post by P380NarvikEclipse » Wed Mar 07, 2018 11:29 pm

WagMatt wrote:
Wed Mar 07, 2018 10:13 pm
1) Sometimes when I start the car and drive off, the drivers info page doesn't load the Sat Nav screen. It just shows the image of the car. Now I have tried what I believe is everything to get it to show the sat nav but the only thing that works is to turn the car off and walk away, then come back and restart it from fresh.
Any one else had this issue?

2) SatNav again: on the drivers display, when you have a route to follow it sometimes gives you a couple of options of route as you are driving. Now, on the Main Sat Nav centre screen it tells you what time saving you will get by going either of these routes, but the drivers sat nav screen shows the START time of your journey for both route options... So if I leave home at 1000am, the main screen will say, go this way and you will arrive at 1050am or go this way and you will arrive at 1045am. But the drivers screen shows both routes as 1000am.....! No use at all!
1. Yes, had this issue previously with the same get out, lock, wait, get back in to reset the unit. The 17C software update has seemingly fixed it for me though, so ask your dealer if they're updating it. I have noticed on random occasion the profile of the velar will show up for a short ~30 second period and then the Nav will show up in the dash, but previously it wouldn't go away.

2. Hmm, I actually haven't paid attention to that. Will take a look on the next journey and let you know if that's changed with the update as well.


Glad you're enjoying the ride either way! Your dealer seems to be top notch in taking responsibility, so that's great.
‘18 RR Velar R-Dynamic SE P380, Narvik Black wrapped in Xpel Stealth PPF, Eclipse interior


SpokenHands
Posts: 234
Joined: Mon Feb 05, 2018 8:40 am
Location: UK

Puncture on day 2

Post by SpokenHands » Tue Mar 27, 2018 8:21 pm

After driving over a decade in a succession of BMWs with run flat tyres, I take delivery of a Velar FE and on day 2 have a slow puncture on the nearside front tyre.

Called Land Rover Assistance and they were around in under 30 minutes to stick the car on the space saver spare tyre. Wondering if I should take the tyre to a local tyre garage or back to the dealer? Probably just the local tyre shop so long as they don't damage the alloys.
2018 D300 Range Rover Velar First Edition
2017 AMG GT-C Coupe
2013 BMW 6-Series Gran Coupe


mge.92
Posts: 412
Joined: Thu Apr 20, 2017 8:51 pm
Location: London, UK

Re: Tech Issues

Post by mge.92 » Tue Mar 27, 2018 8:24 pm

WagMatt wrote:
Wed Mar 07, 2018 10:13 pm
Hi all,

I see there are a lot of posts already but I don't have the time to go through everything to see if my issues are there!

Just got my Velar back after a "mouse" got into engine bay and ate an emissions wire causing the car to break down on me on the highway! Also had a list of things for them to look at but nothing too drastic.
Thankfully Land Rover footed the bill of replacing the wire and also giving me a new rear tire after they found a slow puncture.... I'm happy as those 22 inch wheels are expensive! The fact they replaced the wrong tire requiring another trip to Land Rover was an honest mistake!

Anyway sorry to ramble but here are my remaining problems:

1) Sometimes when I start the car and drive off, the drivers info page doesn't load the Sat Nav screen. It just shows the image of the car. Now I have tried what I believe is everything to get it to show the sat nav but the only thing that works is to turn the car off and walk away, then come back and restart it from fresh.
Any one else had this issue?

2) SatNav again: on the drivers display, when you have a route to follow it sometimes gives you a couple of options of route as you are driving. Now, on the Main Sat Nav centre screen it tells you what time saving you will get by going either of these routes, but the drivers sat nav screen shows the START time of your journey for both route options... So if I leave home at 1000am, the main screen will say, go this way and you will arrive at 1050am or go this way and you will arrive at 1045am. But the drivers screen shows both routes as 1000am.....! No use at all!


Anyway sorry for writing so much. I get carried away. Other than this I fooking love the Velar. Head turning esp in the silicon silver with black package and the 22 inch black rims!!!

Cheers and good day,

Matt
What helps for 1 is to let everything load and for the message to disappear on the main pop up screen before doing anything. If you press continue more often than not it will cause issues.
Marc
SOLD - 13 BMW X3 28i, Carbon Black, Fully Loaded, Tuned and Featured on Smoking Tire
18 Velar R-Dynamic HSE D300, Carpathian Grey / Vintage Tan / Ebony, Fully Loaded


Post Reply

Return to “Faults & Technical”